I2C-Package für neue CODESYS-Versionen

Beim Öffnen vom „Horter_Kalb_Raspi_Support_IO_driver_Example.Project“  kommt es zu mit der neuesten Version der CODESYS-Entwicklungsumgebung gibt es zahlreiche Meldungen. Hier wird beschrieben wie das Demo-Projekt hochgerüstet werden kann.

Projektumgebung hochrüsen

Die erste Meldung kommt kurz nach dem Öffnen des Projektes

“Die im Programm verwendete Compiler-Version ist nicht die neueste. Es wird empfohlen auf 3.5.7.20 zu aktualisieren”

Hier muss einfach die Aktualisierung bestätigt werden.

CODESYS Compiler-Version aktualisieren

CODESYS Compiler-Version aktualisieren

Nach einiger Zeit bekommt man im Ausgabefenster die Meldung

“3 Fehler 12 Warnung(en)”

CODESYS Runtime Version hochrüsten

Jetzt muss ein Update der  Codesys-Runtime-Version angestoßen werden.

  • Update suchen
  • Download starten
  • Installation starten
Update CODESYS Control for Raspberry PI

Update CODESYS Control for Raspberry PI

Gerät aktualisieren

Danach noch das Gerät (Device) aktualisieren.

Danach sollte sich das Programm wieder problemlos kompilieren lassen.

Gerät aktualisieren

Gerät aktualisieren

Visualisierungsprofil aktualisieren

Beim Update auf die Version 3.5SP8 kommt es eventuell zu folgender Fehlermeldung

Das gerade verwendete Visualisierungsprofil funktioniert mit der aktuellen Compilerversion nicht richtig. Bitte aktualisieren Sie das Visualisierungsprofil oder verwenden Sie eine ältere Compilerversion

Zum aktualisieren des Visualisierungsprofils gehen Sie auf

Projekt – Projekteinstellungen – Visualisierungsprofil

Dort wählen Sie die aktuelle Version aus 3.5SP8 aus und bestätigen mit weiter.

Danach sollte sich das Projekt mit F11 fehlerfrei übersetzen lassen.

Visualisierungsprofil ändern

Visualisierungsprofil ändern

Runtime-Version auf dem Raspberry aktualisieren

wenn beim Verbindungsversuch folgende Fehlermeldung erscheint

“Das ausgewählte Zielsystem stimmt nicht mit dem verbundenen Gerät überein”

muss die Runtime-Version auf dem PI aktualisiert werden.

Runtime auf dem Raspberry aktualisieren

Runtime auf dem Raspberry aktualisieren

Sollte es beim Übertragen zu folgender Fehlermeldung kommen

no space left on device

muss der Raspberry komplett neu aufgespielt werden.

Verschiedene Projektversionen zum Download

Programmversion   I2C Beispielprojekt
CODESYS 3.5 SP7 P1
CODESYS 3.5 SP7 P2
CODESYS 3.5 SP7 P3
  Horter_Kalb_Raspi_Projekt_3.5SP7P1 (789 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP7P2 (556 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP7P3 (636 Downloads)
CODESYS 3.5 SP8
CODESYS 3.5 SP8 P2
CODESYS 3.5 SP8 P3
CODESYS 3.5 SP8 P4
  Horter_Kalb_Raspi_Projekt_3.5SP8 (689 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP8P2 (528 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP8P3 (535 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP8P4 (591 Downloads)
CODESYS 3.5 SP9
CODESYS 3.5 SP9 P3
 3.5.9.0
3.5.9.30
Horter_Kalb_Raspi_Projekt_3.5SP9 (684 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP9P3 (571 Downloads)
CODESYS 3.5 SP10
CODESYS 3.5 SP10 P2
 3.5.10.0
3.5.10.20
Horter_Kalb_Raspi_Projekt_3.5SP10 (568 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP10P2.zip (547 Downloads)
CODESYS 3.5 SP11
CODESYS 3.5 SP11 P2
 3.5.11.0
3.5.11.20
 —
Horter_Kalb_Raspi_Projekt_3.5SP11Patch2 (502 Downloads)
CODESYS 3.5 SP12
CODESYS 3.5 SP12P2
 3.5.12.0
3.5.12.20
Horter_Kalb_Raspi_Projekt_3.5SP12 (501 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP12P2 (482 Downloads)
 CODESYS 3.5 SP13  3.5.13.0 Horter_Kalb_Raspi_Projekt_3.5SP13 (226 Downloads)
CODESYS 3.5 SP14 3.5.14.0 Horter_Kalb_Raspi_Projekt_3.5SP14 (386 Downloads)
CODESYS 3.5 SP15
CODESYS 3.5 SP15P2
3.5.15.0
3.5.15.20
Horter_Kalb_Raspi_Projekt_3.5SP15 (264 Downloads)
Horter_Kalb_Raspi_Projekt_3.5SP15P2 (152 Downloads)
     
Speichere in deinen Favoriten diesen permalink.

23 Kommentare

  1. Sehr geehrter Herr Horter,
    ich wollte mal das I2C Projekt ausprobieren und bekomme Fehler im Codesys 3.5.15.30.
    Im Geräte Repository können die Geräte I2HA, I2HE und I2HAE nicht mehr aus dem Codesys Store geladen werden.
    Folgende Melddungen erhalte ich im Fenster “Download fehlender Geräte durchführen”
    – I2HA (Digiatl Outputs) IO driver, 1.0.0.0 (Horter & Kalb) Datei nicht gefunden! Vielleicht wird die Datei vom OEM bereitgestellt.
    – I2HE (Digiatl Inputs) IO driver, 1.0.0.0 (Horter & Kalb) Datei nicht gefunden! Vielleicht wird die Datei vom OEM bereitgestellt.

    Können sie mir die Dateien zur Verfügung stellen oder sind diese auf ihrer Homepage zu finden?

  2. Sehr geehrter Herr Horter,
    nach dem Start des Demo Projektes erhalte ich immer die Meldung “Eine oder mehrere Bibliotheken dieses Projekts konnten nicht geladen werden”
    Im Meldungsfenster werden zahlreiche Bibliotheken angemeckert

    • Kommen die Fehlermeldungen kommen wenn Sie unser Demo-Projekt aufmachen?
      Dann passt was mit der Installation oder mit den Rechten auf dem Rechner nicht.
      Bei manchen Kunden kommt eine Fehlermeldung wegen der IoDrvGPIO. Die ist bei neueren Installationen nicht mehr mit drin.
      Die kann ich Ihnen zuschicken oder Sie ziehen sich die lib von einem anderen Rechner runter.
      Gruß, J. Horter

      • Guten Morgen Her Horter,
        ich habe jetzt eine Lösung gefunden:
        Man löscht alle Bibliotheken aus dem Bibliotheksverwalter, die fehlerbehaftet sind. Anschließend installiert man diese neu. Dann war der Fehler weg.
        Vielleicht hilft das ja auch anderen Kunden von Ihnen 😉

  3. Hallo,
    ich hatte bis jetzt mit Codesys 3.5 SP10 gearbeitet und stoße auf einige Probleme meine bestehendes Projekt in eine neuere Version rein zu laden.
    Habe Codesys 3.5 SP15 mit allen Packages neu aufgesetzt, mein Raspi Projekt rein geladen und die fehlenden Bibliotheken installiert.
    Es wird aber immer wieder der IoDrvGPIO 1.0.1.10 angemeckert den Codesys nicht mehr vom Server bekommt. Diesen hatte ich mir aus dem alten System gezogen und installiert. -> ohne Erfolg

    Das Projekt baut nun auf der damaligen Vorlage von Ihnen auf. Gibt es da eine elegante Methode das hin zu biegen ohne das Projekt auf der aktuellen Vorlage neu aufzusetzen ?

    Vll. habe ich auch etwas übersehen da ich mich von 0 selbst durch fuchsen muss. Komme eig. aus der Honeywell ecke.

    MfG

    • das Problem hatte ich schon gemeldet bekommen. Warum in den neuen Installationen der Treiber fehlt kann ich leider auch nicht nachvollziehen.
      Wenn die aber nachinstalliert wird sollte der Fehler eigentlich nicht mehr auftreten.
      Bitte die IoDrvGPIO.library vom alten System kopieren und installieren.

      • Hallo Herr Horter,

        es klappt.
        Ich habe nochmal mit klarem Kopf alles sauber neu Installiert.
        Meine Packages installiert und ggf. aktualisiert.
        – Codesys Control für Raspberry
        – Horter & Kalb
        – Oscat

        Mein Projekt eingelagert welches mit Codesys 3.5 SP10 erstellt wurde. Alles auf “neuest” gesetzt und aktualisiert.

        Ein wenig ärgert es mich das ich nicht 100pro weiß was ich nun richtig gemacht habe aber ich bin froh das es weiter gehen kann.
        Werde also bald wieder bei euch einkaufen.

  4. Hallo, ich arbeite mit der aktuellen Codesys Version
    V3.5 SP15 Patch 1 (65-bit)

    wenn ich mein Programm übersetze, bekomme ich folgende Fehlermeldung:

    C0338: Die Bibliothek’cmperrors interfaces,3.5.5.0 (System)’wird nur in 32-Bit-Applkationen unterstützt

    Bedeutet das für mich, dass ich eine Codesys Version mit 32 bit verwenden muss, oder wie gehe ich jetzt vor?

    • Hallo Tobias,
      bei mir läuft Codesys in einer 64-Bit-Win7-VM als 64-Bit Anwendung ohne Probleme.
      Hast du unser Demo-Projekt verwendet?
      I2C-Package für neue CODESYS-Versionen
      CODESYS 3.5 SP15 3.5.15.0 Horter_Kalb_Raspi_Projekt_3.5SP15

      • Wir haben dasselbe Problem unter Windows 10 Education:

        CODESYS 64 3.5.15.20 liefert diese Fehlermeldung
        (mit dem aktuellen Horter_Kalb_Raspi_Projekt_3.5SP15P2),

        CODESYS 3.5.15.20 (32 Bit) läuft …

        Es war nicht möglich, die Bibliothek “cmperrors interfaces,3.5.5.0” im 64-Bit-Codesys auszutauschen!

  5. Hallo Herr Horter,
    gibt es schon das Beispielprojekt für die neue Version 3.5.15.0?
    …es wurde zwar alles fehlerfrei mit dem Beispielprojekt 3.5.14.0 kompiliert, jedoch läuft der Master nicht.

    Gruß
    H.Bräuer

  6. Hallo,
    ich habe mir die Projektversion 3.5.14.0 heruntergeladen und das Projekt “Horter_Kalb_Raspi_Support_IO_driver_Example.Project” geöffnet, allerdings tritt beim Kompilieren der Fehler “Bibliothek IoDrvGPIO 1.0.1.10 (3S – Smart SOftware Solutions GmbH) konnte nicht eingefügt werden:” auf.
    Im Bibliotheksrepository findet man die IoDrvGPIO 3.5.11.0.
    Mit dem bestehenden Fehler kann das Programm allerdings nicht auf den Raspberry geladen werden.

    Wie kann ich den Fehler beheben?

    Gruß L

  7. Hallo,

    gibt es den Download auch für V3.5 SP11 Patch2.

    Beim Laden erscheint die Meldung “Eine oder mehr Bibliotheken….”

    Wird dies bestätigt, so werden 58 Fehler ausgegeben.

    Es startet automatisch die “Projektumgebeung, in der empfohlen wird auf Version 3.5.11.20 zu aktualisieren. (Die Compilerversion im Projekt wird mit Version 3.5.6.30 angezeigt.

    Wird auf die V3.5.11.20 aktualisiert sind es dennoch 33 Fehler…

    Gruß T

  8. Hallo Herr Horter,
    seit Codesys V3.5 SP11 und Codesy Control for Raspberry PI 3.5.11. wird der Raspberry PI Zero unterstützt. Bis jetzt ist es mir nicht gelungen den RP Zero mit den I2C-Modulen zum Laufen zu bringen. Mit dem RP 3 klappt alles wie gewohnt. Ein Testprogramm das nur die GPIO des RP Zero verwendet funktioniert ebenfalls. Haben Sie mir einen Tipp der mich weiter bringt?
    Beste Grüße
    Martin

    • Jürgen Horter
      Jürgen Horter

      Hallo,
      haben Sie schon mal versucht ob mit i2cdetect -y 1 die Module gefunden werden?
      Vielleicht muss beim PI-Zero der I2C-Bus noch extra aktiviert werden.
      Gruß,
      J. Horter

  9. Hallo,

    Ich habe alles befolgt, wie es beschrieben wurde. Ich bekomme trotzdem beim Start angezeigt das einige Bibliotheken nicht geladen wurden.

    Es kommen außerdem über 100 Fehlermeldungen, bei der mir Google leider keine Lösungsmöglichkeit bietet.

    3 der 100 Fehlermeldungen sehen so aus und beziehen sich aufs IO GPIO:

    [FEHLER] iodrvgpio, 1.0.1.10 (3s – smart software solutions gmbh): IoDrvReadInputs [IoDrvGPIO](Zeile 4 (Dekl)): C0046: Bezeichner ‘IoConfigConnectorMap’ nicht definiert

    [FEHLER] iodrvgpio, 1.0.1.10 (3s – smart software solutions gmbh): IoDrvReadInputs [IoDrvGPIO](Zeile 9, Spalte 1 (Impl)): C0046: Bezeichner ‘dwNumOfChannels’ nicht definiert

    [FEHLER] iodrvgpio, 1.0.1.10 (3s – smart software solutions gmbh): IoDrvReadInputs [IoDrvGPIO](Zeile 9, Spalte 1 (Impl)): C0004: ‘dwNumOfChannels’ ist keine Komponente von ‘pConnectorMapList[i]’

    Hätten sie einen Rat?

    • Jürgen Horter
      Jürgen Horter

      Hallo Max,
      mit welcher Codesys-Version arbeiten Sie?
      Haben Sie das passende Beispielprojekt geladen?
      Eventuell müssen die Zugriffsrechte auf “Jeden” erweitert werden.
      Gruß, JH

Schreibe einen Kommentar zu Heiko Bräuer Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht.